Ayuda con PostFix

sermaudu

Lanero Reconocido
29 Ago 2003
582
Pego el mensaje que coloque en otro post y que fue el inicio del problema

necesitro ayuda, por alguna extrana razón, al reiniciar el servidor este ya no fue capas de leer el hda3 y pailas el equipo no arranca,
esto fue lo que pasó
generalmente el equipo permanece en inicio de sesión, necesitaba hacer unos cambios a las listas de acceso a internet, me logueé como root y salió un error de memoria insuficiente y quedó en modo de consola; como en este modo no se ni m, pense que era un error menor le di reboot, al cerrar algunos procesos salieron varios errores, reinició, salio la pantalla del grup, escogí la versión del kernel y @#$%&, esta vaina no arrancó, el error que sale es este.
buffer I/O error on device hda3, logical block 1
. .
. .
. .
buffer I/O error on device hda3, logical block 35
mkrootdev: label / not found
mount: error 2 mounting ext3
pivotroot: pivot_root(,/sysroot/initrd) failed: 2
umount /initrd/proc failed: 2
kernel panic - not syncing: No init found. Try passing init = option to kernel.

¿Hay alguna forma de reparar esto?

--------------------------------------------------
fue necesario que viniera el técnico a reinstalar( :muerto: no tengo instaladores), la instalación marchó regular porque siguieron los problemas en las particiones, no fue posible rescatar nada de las configuraciones anteriores asi que toco configurar todo desde 0,
squid ... ok
postfix ... ???
este servicio arranca normal
1)el servicio no da respuesta en el puerto pop
2)el tecnico creyó conveniente instalar el cyrus para transporte imap ???
3)despues de mucho cacharrear reconoce a un usuario que hace que envia y recibe pero quien sabe a donde
4)cuando logra identificar otro usuario sale error unable to locate maildrop

cabe anotar que se ha tratado de instalar en base a la información de sistemas ya preinstalados y tutoriales en el web

anteriormente cuando yo creaba un usuario en linux este quedaba automaticamente con correo; ahora como van las cosas para crear un usuario de correo hay que hacerlo por el terminal...

la madre yo ya tenia funcionando mi servidor al pelo y quiero que vuelva a quedar así, asi que necesito su ayuda.

no entiendo cual es la necesidad del cyrus, el fedora solo trae el postfix y deberia ser mas que suficiente.
 

HsolraC

Lanero Camellador
14 Jun 2004
1,978
Ya lo arrancaste desde un live cd (como Knopixx) para verficar que la particion este bien, tiene cara de no estarlo.
 
12 May 2003
5,087
1. Eso es porque Postfix no es un pop3 server. Si quiere pop3 pues instale un servidor de pop3.
2. El tecnico instalo el servidor de imap que mas le gusta/conoce. Cual es el problema?
3. Informacion insuficiente
4. Informacion insufuciente

Ya creo los usuarios?
 

sermaudu

Lanero Reconocido
29 Ago 2003
582
cahebebe: ya se reinstalo y hasta ahora servidor "anda bien",(por que los servicios quedaron configurados a medias)

Krieg:Listo ya entendí lo del cyrus, el problema es que antes yo creaba un usuario en linux y listo este ya tenia cuenta de correo....
Lo que tengo ahora y despues de haberle cacharreado mucho es un sistema que envia correo de forma local nada mas(antes hacia que mandaba), pero desde la maquinas clientes no recibe, a veces cuando esta corriendo el saslauth en el equipo cliente sale que no encuentra la carpeta maildrop; corri el cyradm pero no es capas de logearse con la cuenta del administrador---sale login invalid.
Creanme llevo tres dias en turnos de 18 horas modificando todos los .conf que encuentro por ahi, ya me he recorrido el google, tengo guardados como 20 manuales , unos que con cyrus, sals, tls y yo no se cuantas cosas mas otros con mysql, otros con courier. :(
he tratado de seguir el de cyrus, pero llega un punto en que tengo que trabajar con cyradm y pailas, ya no se que hacer y no confio mucho en el servicio técnico ya que en esta area parece estar mas perdido que yo.

Cualquier ayuda de verdad se las agradesco
 
12 May 2003
5,087
Y porque no instala el mismo imap server que tenia antes de que reinstalara la maquina?

Tambien puede probar instalando el uw-imap, es el imap server mas facil de configurar.

Y realmente necesita imap? No le basta con pop3?
 

sermaudu

Lanero Reconocido
29 Ago 2003
582
Hola krieg, el problema es que con la reinstalación se perdió todo.
Lo del imap y el pop, pues ahi si ando un poco perdido ya que supuestamente instalaron el cyrus para dar transporte pop y termino abriendo el puerto 143, en un principio daba respuesta en los dos puertos ahora ya no se, esta vaina ya me la está volando.
Voy a probar con el programa que me dijo, tiene conpatibilidad con el postfix o es independiente
 
12 May 2003
5,087
Ud lo que esta es como confundido y/o no sabe bien como funciona el mail.

Un servidor de imap sirve .... imap!
Si quiere un servidor de pop3 pues instale un servidor de pop3.

Y postfix no tiene nada que ver en esto, postfix es solo para que envie y reciba el mail.

Si ud lo que necesita es un servidor de pop3 (que es lo que yo creo y por eso se lo pregunte antes) no entiendo que hace dandole con un servidor de imap. Es como si ud necesitara montar una papeleria en Bogota y estuviera montando una carniceria en Cali.

Si ud simplemente quiere que los usuarios desde otras maquinas (clientes) bajen el mail que ya esta en el servidor, con un servidor de pop3 lo puede hacer (y no tiene que meterse para nada con imap). Yo personalmente uso qpopper porque es el mas sencillo de instalar.
 

sermaudu

Lanero Reconocido
29 Ago 2003
582
hay alguna forma de instalar el fedora u otra distribución en servidor con un disco scsi(el disco esta montado sobre una tarjeta adaptadora tekram, esta traia unos drivers para sco pero no los reconoció, descargué de el distribuidor unos drivers que venian en formato .img pero estos pesaban mas que el diskette y hay si como se le hace? ya que al momento de instalar solo da la opción de leer desde el diskette), ya que cuando traté de instalar el fedora no reconoció el disco....

sigo trabajandole al chicharron anterior... vamos a ver como me va
 

sermaudu

Lanero Reconocido
29 Ago 2003
582
con lo del chicharron anterior(postfix) arreglado
solución activar las opciones de ipop3 e imapd en la carpeta xinetd

la instalación de linux en servidor con disco scsi solo permitió rh9, el fedora 2 no reconoció los drivers