Ayuda para instalar paquetes en Ubuntu 6.10

Tael Yang

Lanero Reconocido
8 Nov 2004
503
LANeros necesito ayuda con lo siguiente . . .

como por mi casa no hay banda ancha y en el trabajo si, alli tengo instalado Ubuntu 6.10, al igual que en casa, entonces en el trabajo me descargo las actualizaciones y el software que necesito y luego lo llevo a casa en cds . . .

tratando de instalar unas actualizaciones me tire el sistema, ahora cuando voy a instalar los paquetes (.deb) con la orden "dpkg -i /ruta/*.deb" me dice despues de dos minutos que el proceso a finalizado ya que hay demaciado errores, lo que no me salia cuando los instalaba uno a uno o por grupos.

el problema se me hace (me corrigen por favor) que es porque hay paquetes que dependen de otros, que deberian estar ya instalados, la pregunta es si hay alguna forma de ver que paquetes dependen de otros que deberian estar preinstalador, o si ubuntu tiene alguna forma de instalar muchos paquetes (tengo como 200) y que cada que se necesite uno como prerrequisito para otro le pida a uno la ubicacion o algo asi.

Hay disculplan la jodedera pero es con animo de dejar mi ubuntu al pelo, haber si algun dia dejo windows.

Gracias a todos

Suerte!!!
 

swoko

Lanero Reconocido
12 Dic 2003
1,140
Bueno, si no me equivoco, la razón es que no deberías instalarlos con el dpkg sino con el apt-get.

Creo que uno se puede bajar los repositorios completos en DVD e instalar desde ahi.
 

lordhellriser

Lanero Reconocido
31 Mar 2004
1,519
tratando de instalar unas actualizaciones me tire el sistema, ahora cuando voy a instalar los paquetes (.deb) con la orden "dpkg -i /ruta/*.deb" me dice despues de dos minutos que el proceso a finalizado ya que hay demaciado errores, lo que no me salia cuando los instalaba uno a uno o por grupos.

a que error en especifico se refiere. con respecto a que paquetes.

el problema de instalar asi como usted hizo es que facilmente se puede corromper la base de datos apt de su ubuntu. tiene que ubicar que paquete o paquetes son los que estan bloqueando apt y eliminarlos o reinstalarlos.

pruebe con este comando luego:

sudo dpkg --configure -a
 

Tael Yang

Lanero Reconocido
8 Nov 2004
503
el error es el que dije anteriormente, osea por ejemplo va a instalar el xmms, y dice que no encunentra una libreria de C por ejemplo, ahi va un error y asi con varios archivos, al final me dice que finalizo por que hubieron mucho errores en el proceso
 
12 May 2003
5,227
dpkg le sirve para instalar un paquete manualmente pero ya para instalar cientos de paquetes no es la mejor forma porque va a tener problemas con la resolucion de dependencias. Me imagino que todo esto es para hacer una actualizacion masiva pero no tiene conexion a Internet asi que esta llevando los paquetes manualmente al equipo.

Ponga todos los .deb en /var/cache/apt/archives y actualice con apt-get. Probablemente le conviene configurar su equipo para usar un repositorio local en lugar de los de Internet. En el /etc/apt/sources.list deshabilite todos los repositorios (poniendole un '#' al comienzo de cada linea) y agregue una linea asi:

file:/var/cache/apt/ archives/

Luego puede usar 'apt-get update' y 'apt-get install my-paquete' o 'apt-get upgrade' normalmente.
 

Tael Yang

Lanero Reconocido
8 Nov 2004
503
Viejo Muchas Gracias

Krieg dijo:
dpkg le sirve para instalar un paquete manualmente pero ya para instalar cientos de paquetes no es la mejor forma porque va a tener problemas con la resolucion de dependencias. Me imagino que todo esto es para hacer una actualizacion masiva pero no tiene conexion a Internet asi que esta llevando los paquetes manualmente al equipo.

Ponga todos los .deb en /var/cache/apt/archives y actualice con apt-get. Probablemente le conviene configurar su equipo para usar un repositorio local en lugar de los de Internet. En el /etc/apt/sources.list deshabilite todos los repositorios (poniendole un '#' al comienzo de cada linea) y agregue una linea asi:

file:/var/cache/apt/ archives/

Luego puede usar 'apt-get update' y 'apt-get install my-paquete' o 'apt-get upgrade' normalmente.

Viejo muchas gracias, ahorita en hora de almuerzo lo pruebo
 

Tael Yang

Lanero Reconocido
8 Nov 2004
503
Nada, No Me Da

Krieg dijo:
dpkg le sirve para instalar un paquete manualmente pero ya para instalar cientos de paquetes no es la mejor forma porque va a tener problemas con la resolucion de dependencias. Me imagino que todo esto es para hacer una actualizacion masiva pero no tiene conexion a Internet asi que esta llevando los paquetes manualmente al equipo.

Ponga todos los .deb en /var/cache/apt/archives y actualice con apt-get. Probablemente le conviene configurar su equipo para usar un repositorio local en lugar de los de Internet. En el /etc/apt/sources.list deshabilite todos los repositorios (poniendole un '#' al comienzo de cada linea) y agregue una linea asi:

file:/var/cache/apt/ archives/

Luego puede usar 'apt-get update' y 'apt-get install my-paquete' o 'apt-get upgrade' normalmente.

hago todo lo que vos me dijiste, comento " # " todas las demas fuentes, agrego esta linea " file:/var/cache/apt/archives/ " y me dice lo siguiente

E: Tipo 'file:/var/cache/apt/archives/' desconocido en la línea 46 de lista de fuentes /etc/apt/sources.list
E: No se pudieron leer las listas de fuentes.

Estoy que me traigo el pc de la casa pa el trabajo . . . !!!
 

Tael Yang

Lanero Reconocido
8 Nov 2004
503
Viejo ya lo puse con y sin espacios, eso fue lo primero que hice, espacios al inicio al final, asi como vos me lo enviaste, mejor dicho de todo y nada, hasta puse los *.deb en otra carpeta y nada
 

Tael Yang

Lanero Reconocido
8 Nov 2004
503
Por fin ¡CARAJO! aun me presenta algunos problemitas de dependencias pero eso es lo de menos.

Gracias Viejo Krieg.

Otro Paso Mas Pa Dejar Güindows CARAJO!