:: Foro Oficial de Algoritmos ::

Kaamos

Lanero Reconocido
25 Feb 2007
1,668
Buenas compañeros.

Quisiera preguntarles, en PSeint, que comando se utiliza para mostrar en pantalla el resultado, digamos cada 5 segundos y que no aparezca todo inmediatamente.

Mas exactamente es este ejercicio:

Código:
Proceso sin_titulo
	Escribir "Cuantas veces quiere que le cante? ";
	Leer Cantidad;
	Para A<-1 Hasta Cantidad Con Paso 1 Hacer
		Si A<=1 Entonces
			Escribir A, " Elefante se balanceaba sobre la tela de una arania, como la tela si resistia";
		Sino
			Escribir A, " Elefantes se balanceaban sobre la tela de una arania, como la tela si resistia";
		FinSi
	FinPara
FinProceso

Lo que busco entonces es, si el usuario quiere que la cancion se cante unas 10 veces, como hago para que en pantalla muestre la cancion, frase por frase separados de unos cuantos segundos????
 

Kaamos

Lanero Reconocido
25 Feb 2007
1,668
Buenas, se inicio semestre y de nuevo yo aqui con duditas jejejje

esta vez ya con vectores.

Como hago para recorrer un vector y al final mostrar un mensaje donde me indique el total de numero digitados, y la cantidad de numeros de un solo digito???

esto es lo que tengo del algoritmo:

Código:
Proceso sin_titulo
	//programa para leer numeros y almacenar en un vector
	Dimension tam[20];
	
	c<-0
	
	Escribir "Programa para leer numeros y almacenar en un vector"
	
	Para val<-1 Hasta 20 Con Paso 1 Hacer
		Escribir "Digite el ", val, " numero";
		leer tam[val];
		si tam[val] = 0 entonces	//condicion para terminar el programa cuando se digite 0
			val<-21
		finsi
	FinPara
	
	Para val<-0 Hasta tam[val] Con Paso 1 Hacer
		a<-trunc(tam[val]/10) = 0
		si val <> a entonces
			
			c<-c+1;
			
		finsi
	FinPara
	Escribir "El total de numeros digitados es:", val 
	Escribir "La cantidad de numeros de un digito es:", c
FinProceso

Se que tengo algo mal en el segundo Para, pero no he podido dar con el chiste. Gracia
 

Kaamos

Lanero Reconocido
25 Feb 2007
1,668
Buenas tardes.
Vengo con una duda respecto a Vectores.

El ejercicio en si es: teniendo un vector a[] pasar a un vector b[] de misma dimesion, la cantidad de digitos de cada numero ingresado en el vector a.

El ejercicio como lo entiendo, lo hago con un PARA, dentro el ejercicio correspondiente para conocer los digitos del numero almacenados y luego pasar al vector b.

Este es el ejercicio en cuestion:
NOTA: el ejercicio trae unas variables que corresponden a funciones del ejercicio que no escribi para evitar mostrar mas extenso el algoritmo (pero que funcionan bien)

Estoy trabajando en PSEINT

Código:
Proceso sin_titulo
	//programa para leer numeros y almacenar en un vector
	Dimension tam[20], cdig[20];
	c<-0
	tval<-0
	d<-0
	primos<-0
	cont<-0
	num<-0
	Escribir "Programa para leer numeros y almacenar en un vector"
	
	Para val<-1 Hasta 20 Con Paso 1 Hacer
		Escribir "Digite el ", val, " numero";
		leer tam[val];
		f<-val
		si tam[val] = 0 entonces	//condicion para terminar el programa cuando se digite 0
			val<-21
		finsi
	FinPara

	//Cantidad de digitos almacenados en el segundo vector 
	Para cod<-1 Hasta f-1 Con Paso 1 Hacer
		leer cdig[cod]
		a<-0
		Mientras f<>0 Hacer
			f<-trunc(f/10)
			a<-a+1
		FinMientras
		a<-cdig[a]
	FinPara

	Escribir cdig[cod]
FinProceso

Espero me pueda ayudar.
Gracias